[libre-riscv-dev] [Bug 99] IEEE754 *pipelined* FPDIV unit needed

bugzilla-daemon at libre-riscv.org bugzilla-daemon at libre-riscv.org
Fri Jun 28 08:20:04 BST 2019


--- Comment #7 from Jacob Lifshay <programmerjake at gmail.com> ---
All the short variable names need at least a comment at the definition with the
full name, otherwise it's quite hard to understand at first. For instance, in
FPRoundData, self.oz is very difficult to guess at first.
In my opinion, short variable names (fragments of words) are only appropriate
for widely accepted names such as i, j, k for iteration, or widely known
abbreviations, such as num instead of number, or for cases where the definition
is immediately adjacent to all uses.
out_do_z should be out_do_zero, or, better yet, result_is_zero. FPRoundData.z
is totally unintelligible (it's not zero), I would name it base or have
FPRoundData extend FPNumBaseRecord.

There comes a certain point where the additional readability from the reduction
in lines of code is entirely negated by the lack of comprehensible names.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-riscv-dev mailing list