[libre-riscv-dev] vliw idea naming

Jacob Lifshay programmerjake at gmail.com
Mon Jun 24 11:27:17 BST 2019

I want to read over all your svprefix changes a little more before I answer
your questions.

the vliw idea sounds like a good idea, though I would call it a vector
block or something like that -- it's much more similar to arm's thumb2 IT
instruction (adds predicates for up to 4 following instructions) than
traditional vliw, since the operations still appear to execute sequentially
and the processor can internally reorder them.


More information about the libre-riscv-dev mailing list