[libre-riscv-dev] [Bug 178] first coriolis2 tutorial, workflow and "test project" page

bugzilla-daemon at libre-riscv.org bugzilla-daemon at libre-riscv.org
Fri Mar 6 18:24:01 GMT 2020


--- Comment #185 from Jock Tanner <tanner.of.kha at gmail.com> ---
(In reply to Luke Kenneth Casson Leighton from comment #183)

> ok great, do you want to alter that in the wiki, to get familiar
> with doing that?

Sure. Do I need an account for that?

> cd ~/soclayout
> cd experiment
> git pull
> make vst
> make view
> that should do it

I tried

> $ git clone ssh://gitolite3@git.libre-riscv.org:922/libresoc.git

to get the source, but first I got password confirmation requests

> gitolite3 at git.libre-riscv.org's password:

and then, after a dozen attempts − 

> ssh: connect to host git.libre-riscv.org port 922: Connection refused

I had my private key in ‘~/.ssh’ folder on chroot environment. Am I doing
something wrong, or is it a thing with the git server?

> you don't want dreal although it is quite pretty (just tried it)
> did you remember "xhost +" in the outside system?
> try "apt-get install xterm" just to see if that's happy.  if not, then you
> may need to do something strange, like install xnest (and set export
> DISPLAY=1.0 or however xnest works), or use ssh -X forwarding or... you get
> the idea.  remember to install and run even the most basic window manager
> onto the Xnest (twm -display :1) otherwise everything ends up top-left
> corner and no window bars
> https://box.matto.nl/xnest.html
> i just tried it, and it works fine.

No no no, it's broken, but in more subtle way. =) `xterm` (and `cgt`) are
working fine just with “DISPLAY=:1”. The problem only applies to `dreal`.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-riscv-dev mailing list