[libre-riscv-dev] [Bug 178] first coriolis2 tutorial, workflow and "test project" page

bugzilla-daemon at libre-riscv.org bugzilla-daemon at libre-riscv.org
Tue Feb 25 10:17:27 GMT 2020


--- Comment #104 from Luke Kenneth Casson Leighton <lkcl at lkcl.net> ---
(In reply to Jean-Paul.Chaput from comment #100)
> Hello Luke,
> I cannot access the git repository anymore. Either through ssh or https.

there's no http or https access for git (only the web "browsing" frontend):
gitweb is running on the git port (9418).

ssh has been moved to port 922 (a habit i picked up 12 years ago
to stop script kiddies).

please try this and send the results back:

ssh -v -p922 gitolite3 at git.libre-riscv.org

if it pauses with no action (at all) then you managed to try to log in
with an unauthorised user/pass combination (from the wrong machine, or
with the wrong ssh key).

this would result in the IP address being banned immediately (see below)

> Tried with libre-riscv and libre-soc also. 

libre-soc's not set up yet.

> And looked through the doc
> for any specific instructions but did not found any.


so you want:

git clone ssh://gitolite3@git.libre-riscv.org:922/REPONAME.git

however.... if you've made the mistake of trying to use a username/password
on ssh, the sheer volume of scripted and DDoS attacks against the servers
that i run has led me to get extremely draconian with fail2ban.

you get *one* chance to get an ssh-user/pass login (which you don't have,
because gitolite3 only accepts ssh keys), and fail2ban *WILL* block you
for at least 48 hours.

can you send me (off-list) the IP address that you're ssh'ing in from?
i will check the fail2ban logs and see if it's been added, then whitelist

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-riscv-dev mailing list