[libre-riscv-dev] [Bug 178] first coriolis2 tutorial, workflow and "test project" page

bugzilla-daemon at libre-riscv.org bugzilla-daemon at libre-riscv.org
Fri Mar 6 17:16:37 GMT 2020


--- Comment #183 from Luke Kenneth Casson Leighton <lkcl at lkcl.net> ---
(In reply to Jock Tanner from comment #181)
> (In reply to Luke Kenneth Casson Leighton from comment #173)
> > … i gave serious consideration to scripting a from-scratch
> > source-build of python 3 (which is what you need to do if installing pypy3,
> > which we did a few months ago).
> Did you use pyenv back then? If not, I would highly recommend it.
> (In reply to Luke Kenneth Casson Leighton from comment #180)
> > ok jock i replicated things, all good.  yes you're right, do that symlink
> > for now.  i've updated the page
> > https://libre-riscv.org/HDL_workflow/coriolis2/
> > can you double-check it looks reasonable.
> There was also a minor quirk I did not mention.
> When you do (1.3)
> > git clone https://www-soc.lip6.fr/git/alliance.git
> sources appears in '~/alliance/alliance/alliance/src', not in
> '~/alliance/alliance/src'. The rest of the paths are correct.

ok great, do you want to alter that in the wiki, to get familiar
with doing that?

> > the next thing to do would be to make sure nmigen is installed correctly as
> > well as yosys from latest source code, and try some of the soclayout
> > experiments.
> > some of them aren't fully documented, you can see in this bugreport i say
> > things like "run make vst then python doAlu16.py" rather than just "make
> > lvx", however just go through them and see how you get on ok?
> TBH I could not grasp that instructions at all. =)


cd ~/soclayout
cd experiment
git pull
make vst
make view

that should do it

> I created my `user-LOGIN.mk` and run `make` in a different folders. 

yep you don't want to be running "make", because that picks the first thing
rather than the targetted requirements.

>I came
> to realization that my Arch-hosted chroot is broken: every attempt at `make`
> has ended up in `dreal` segfaulted. But in Debian 10-hosted chroot I managed
> to get either an empty `dreal` window or an error message other than
> segfault.

you don't want dreal although it is quite pretty (just tried it)

did you remember "xhost +" in the outside system?

try "apt-get install xterm" just to see if that's happy.  if not, then you may
need to do something strange, like install xnest (and set export DISPLAY=1.0 or
however xnest works), or use ssh -X forwarding or... you get the idea. 
remember to install and run even the most basic window manager onto the Xnest
(twm -display :1) otherwise everything ends up top-left corner and no window


i just tried it, and it works fine.

we do specifically recommend that the host system is debian, rather than a 
hybrid (not even ubuntu).  this avoids precisely these kinds of issues.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the libre-riscv-dev mailing list